
Many of us have done it: downloaded a demo of Adobe After
Effects, eager to make the plunge into motion graphics. But we
soon find ourselves unable to accomplish even the most basic
of tasks in the program: set some type, draw a line, a circle, a
square, anything. After a few more exasperating minutes, After
Effects is closed and probably never opened again.

On first encounter, After Effects is frustrating to use not
only because of its apparent complexity, but also because of its
misleading familiarity. The program bears a superficial resem-
blance to other Adobe applications, but the way it functions is

completely unique. And even if you’re familiar with Premiere,
After Effects’ video editing cousin, you’re still no further ahead
because Premiere has no more in common with After Effects
than, say, Photoshop does.

While After Effects is indeed the most complex of Adobe’s
apps, developing a good working knowledge of the program is
not beyond the average user of Illustrator or Photoshop (you
may have forgotten: neither of which were particularly easy to
learn). And you’re at a major advantage already because you
know how to build graphics. Yes, good motion graphics skills
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FIGURE 1. The Adobe After Effects WORKSPACE isn't
quite like any other. In the upper left corner is the
Project window. All imported footage (audio, video,
stills), as well as the compositions you create, appear
here. To the right of the Project window is the
Composition window, where animations are
constructed and previewed. In the Toolbox, note that
the Pen and Marquee tools don’t behave like they
traditionally do – both are using for masking and won’t
create or select images. At the bottom of the screen is
the Timeline. The position and length of footage within
an animation’s running time are represented by the
coloured bars to the right of the layer name. Ghosted
areas of the bar are trimmed segments of footage. Two
toggle switches at the right of the layer name –
Collapse Transformations (the star-shaped icon) and
Quality (the diagonal line) – are used to preview at
final render quality. There are three tabs in the
Timeline and Composition windows, indicating three
compositions are currently open. (A very unusual
interface feature: there’s actually a tiny, horizontal
scroll bar at the top of the composition window.) 
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are well within the reach of most print and Web designers, all it
takes is patience, determination, and documentation—which is
where I come in.

So download the After Effects demo again (go to
www.adobe.com/aftereffects) and I’ll walk you through some basic
tasks. We’ll approach this from the perspective of a print designer
(ideally with some Web design experience too). For the sake of
simplicity, I will grossly simplify all tasks and ignore enormous
facets of the program, but such are the compromises of four-page
tutorials. I won’t be touching After Effects’ more daunting fea-
tures, such as Motion Math, Expressions and 3D, which are three
areas that baffle even some experienced AE users.

The final animation you create at the end of this tutorial will
be a random mess, but the point here is to learn how After Effects
functions without worrying about final results. Did you expect to
make beautiful music the first time you picked up a guitar? No,
you were thrilled when you strummed your first clean chord. So
let’s start making a racket.

STARTING YOUR PROJECT 

Let’s cover some minimal basics then go straight to getting our
hands dirty.

The files you create with After Effects are called projects. In
essence, the project file tells After Effects how you’d like to com-
bine your source files—the footage you import: audio, video, or
stills. The individual animations you create with After Effects are
called compositions (or comps, for short). You will not find any
comps on your hard drive, only the project file. Like pages within
a Quark document, compositions can’t be opened individually,
they’re all embedded within your project file. One project could
contain dozens of compositions. You’ll see the project window in
the upper-left corner of your screen. All the files you import and
the compositions you create will appear here.

See Figure 1 for an overview of the After Effects workspace.
To begin, let’s create a new comp (this will simultaneously

start a new project). Hit command-N (control-N on Windows).
Select “Medium, 320 x 240” to create a low-resolution file we can
preview quickly and with minimal memory demands. Call the
composition whatever you like and click OK. You now have a
blank composition.

ANIMATING AN ADOBE ILLUSTRATOR FILE 

Let’s import an Illustrator file (either an EPS or native Illustrator)
and apply a basic transformation. 

Choose File>Import>File or, better yet, hit Command-I (or
double click an empty area of the project window). Drag this file
from the project window to the timeline. (Dragging footage into
the timeline will centre it within the composition window; drag-
ging it directly into the composition window will place its centre
wherever you let go of the mouse.) The file appears in the com-
position window and becomes a layer in the timeline window, de-

faulting to a length of ten seconds. The bar to the right of the file
name represents the file’s length and position within the running
time of the animation. If you wanted to reposition where this file
appears within your animation, just drag this colored bar to move
the footage earlier or later in timeline. To trim footage, grab one
of the grey handles from either end of the bar.

Now let’s animate the size of this graphic. In the timeline,
click the arrow beside the layer and then click the arrow beside
“Transform”. The five properties that appear are the various kinds
of transformations you can apply. (A 3D layer has many more, but
we won’t get into that). Click the stopwatch beside the word
“Scale” to set your first keyframe, then grab the playhead and
move it to about the one-second mark. Click the stopwatch icon
beside “Scale” again to set the second keyframe. Now, click one
of the Scale values and enter “300%”.

Congrats, you’ve just created an animation that scales your art-
work from 100% to 300%. That’s how tweening works in After Ef-
fects, and the other transformations work the same way. It’s pretty

The PROJECT WINDOW
is home to all your After
Effects footage. The file
second from the bottom is
a composition file; the rest
of the files were imported.

For CRISP PREVIEWS of vector artwork, be
sure to check the “Collapse Transformations/
Continuously Rasterize” option in the timeline.

After Effects’ TIMELINE is where you'll spend much of your animation
time. LiveMotion sports a similar, streamlined version of the AE timeline.
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easy and pretty powerful—you can accomplish quite a lot with
these simple skills.

Hit the “Home” key to return to the start of the timeline and
press the space bar to preview the animation. There is one major
problem: your smooth, resolution-independent file gets chunky
when it scales up. Why? The image was only rasterized once
when it was imported. 

To have it continuously rasterized, you need to check the
“Collapse Transformations/Continuously Rasterize” box in the
timeline—it’s the star-shaped icon to the right of the file name.
For best quality previews, also click the “Quality” checkbox just to
the right of “Collapse Transformations”. Remember that these op-
tions will slow down your previews, so only use them when you
want the highest quality. Hit “Home” and then the space-bar to

see the difference this makes (these options only affect the pre-
view, not your rendered file).

After Effects can also recognize layers in Illustrator and Photo-
shop files. For instance, you can place different body parts of a fig-
ure on each layer and animate them separately. But for most of
us, layering in Photoshop and Illustrator is an organizational func-
tion: as long as your image looks pretty, your layers can be a mess.
In After Effects, you’ll want your layers to function as moveable
sections of an image, so you’ll probably want to relayer and save a
copy of your images before importing them.

IMPORTING A PHOTOSHOP FILE 

Now let’s import a Photoshop file and apply another transforma-
tion. Hit command-I and select a Photoshop file with a transpar-
ent background from your hard drive. Notice that After Effects
recognizes Photoshop’s transparency and uses it as an alpha mask.

Let’s animate the opacity of this image, but let’s do it quickly.
Rather than twirling down arrows (which is slow and messy), se-
lect the layer name and hit “T”. This displays the “Opacity” prop-
erty alone. (And why is the shortcut “T”? Well, because “O” was
taken. Just think “T” as in “transparency”.) Below are the other
keyboard shortcuts for transformations:

P - Position S - Scale
R - Rotation A - Anchor Point
Hit “Home” to go to the start of the timeline. Click the stop-

watch beside “Opacity” and decrease its value to 0%. Go to the 1
second mark and increase the value to 100%. Because you already
set your first keyframe, After Effects automatically creates a sec-
ond keyframe when you adjust the opacity value. Hit “Home”
and then the spacebar to preview the animation. The image
should fade in over the span of one second.

Now let’s make this image move across the screen. Select the
layer and hit “P” to display the Position property. Let’s start this
animation at the one-second mark, after the image has faded in.
Go to the one second mark either by dragging the playhead or
clicking the time display in the upper-left of the timeline window
and entering “100”. Move the image to the left of the composition
window. Click the stopwatch to set your first keyframe. Now go to
the two-second mark in the timeline. Move the image to the right
of the composition window. Notice how a dotted line appears,
showing you the motion path of the object.

Hit the “Home” key to return to the start of the animation and
then the spacebar to preview the animation. The object fades in,
then moves from left to right. However, we don’t like the sudden
starts and stops at beginning and end of the object’s motion—it
looks too artificial. Select the Position keyframes by clicking and
dragging a marquee around them both, then go to
Animation>Keyframe Assistant>Easy Ease (or hit F9). This
makes the start and end of the objects’ movements more gradual.

Close this composition. You should now have two composi-
tions in your Project window. Let’s create a third composition.

AFTER EFFECTS FAQ
What is Adobe After Effects?
After Effects is an application which allows you to create motion graphics and
visual effects for broadcast and the Web. The program is used regularly and
frequently in television and film production.

What’s the difference between the standard version and the 
Production Bundle?
Unless you’re a professional in the motion graphics industry, don’t concern
yourself with the extra features in the Production Bundle—the standard
version is all you need. But visit www.adobe.com/aftereffects if you just gotta
know what you’re missing.

Why is After Effects worth learning?
Remember the first time you saw Photoshop and your mind reeled at the
thought of all the things you could do? After Effects is every bit as exciting.
It’s fun, it’s addictive, it’s staggeringly complex.

Can my computer handle After Effects?
If you purchased your computer within the last year, it probably can. If you’re
running a G4 or Pentium 4, you certainly have the processor power. A G3 will
probably try your patience, but my Pentium 3 handles the program at a
respectable clip. For real work, you need around 256 megs of RAM dedicated
to the application. The more complex your project, the more horsepower
you’ll need. Like Photoshop, After Effects will devour as much power as you
can throw at it and still want more. However, you can probably make your
way through this tutorial with 128 MB.

Does After Effects run better on Mac or Windows?
When it comes to performance, After Effects seems to run substantially faster
on a PC. In July/2002 Chris White, pre-eminent tech-head at
www.DigitalVideoEditing.com, published extensive tests which showed the
Mac (running OS 9 and X) being consistently and badly trounced by an array
of different PCs. In real world use, I’ve found Apple’s take on the ‘megahertz
myth’ to be a myth of its own. Of course, the Mac has compelling user
experience advantages, but if raw performance is what you’re after, Wintel
appears to boast superior speed for the moment.

I can’t afford After Effects. What else can I buy?
Unfortunately, nothing. For Windows, After Effects (priced at US$649) has no
significant direct competition. If you’re only interested in adding basic
animation to your video projects, your DV editor can probably handle that.
The timeline in Macromedia Flash MX has dramatically improved, but
Adobe’s under-appreciated LiveMotion is also a fine means of getting
acquainted with After Effects’ timeline, although it only allows you to create
Web animations. And there are some who argue that After Effects itself is as
good or better than either for producing SWF files.

Do I need a digital camcorder or DV footage?
Absolutely not—no DV footage is needed to produce spectacular animations.



CREATING SOLIDS AND SETTING TYPE 

Let’s set a little type—so, where’s the text tool? Alas, things aren’t
quite that simple in After Effects. There is no text tool (and no
line tool and no circle tool and no polygon tool!). In order to cre-
ate anything in After Effects (as opposed to importing it), you
must start with what After Effects calls a “solid”. Solids are blocks
of solid color which are typically masked or treated with an effect,
and they only exist in the timeline, not in the Project window. In
order to create text, we need to create a solid first, then apply an
effect to it. Yes, I know this seems utterly bizarre, but you’ll get
used to it.

Control-click (right-click in Windows) in the timeline and go
to New>Solid. A new layer appears in the timeline. Select it and
go to Effect>Text>Basic Text. In the dialogue box, enter and for-
mat some text. The Effects window pops up when you’re done to
display the text formatting properties. Notice the stopwatches next
to each of the text formatting options? That indicates that all these
elements can be animated. There are a lot of possibilities here—
but let’s not open this particular can of worms just yet.

Let’s try applying another quick effect, something more con-
ventional. With the Type solid layer selected, go to Effect>Per-
spective>Drop Shadow. Adjust the drop shadow properties in the
Effect window to your liking. Hit F3 to show or hide all the effects
that have been applied to a layer.

NEST, PLEASE 

And for my final trick, we’ll throw together all your hard work to
illustrate one of After Effects’ most essential features: nesting.

Create one more composition. Now, simply drag all three of
your previous compositions from the project library and into the
timeline. Each one becomes a layer in the new composition.
When you place a composition within another composition,
that’s nesting. A nested composition then behaves just like any
other layer within a composition. You can’t, however, edit the
nested composition. In order to do that, you have to open the
original comp.

And why nest?  Simple: to keep your timeline from becoming
impossibly convoluted.

Hit “Home” and then the space bar to feast your eyes on what
you’ve created.

FINISHING IT OFF 

At last we’re done, and now you’d like to see a preview that’s rep-
resentative of your final exported movie. Let’s do a RAM preview.
Either hit the play button on the right of the “Time Controls”
palette or hit 0 on the number pad.

What a mess, eh? But, hey—you made it all by yourself.

Kirby Ferguson (e-mail me@kirbyferguson.com) recently completed work on

his sketch comedy video, Goodie Bag. Currently carbon-based in Toronto, he

can be found on the Web at www.kirblooey.com.
For free After Effects tips and tutorials, you can’t you beat the
EXPERT CENTER at Adobe.com (registration required).

Select “IMPORT AS
FOOTAGE” to have
Illustrator or Photoshop
layers import in individual
After Effects layers.

After Effects’ TOOL PALETTE may look familiar, but if you draw
an object with that pen tool or try to select something with that
marquee tool, you’ll get a surprise: both tools are used for
masking and don’t actually create anything.

If you’re going to create
anything directly in After
Effects (rather than import it),
you’ll need to start with a
SOLID. It’s an unorthodox
approach, bound to
temporarily confuse the
average user of Photoshop 
or Illustrator.

SETTING TYPE will also
bewilder the seasoned 
desktop publisher. Type is
created by first making a Solid
layer, then applying the “Basic
Text” effect. Type formatting
options can be seen here in 
the Effects palette.
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